Sonos et Synology : problème de WiFi !

Sonos est un des leader sur le marché des enceintes multiroom et la dernière mise à jour Synology (SRM) peut poser des soucis. Dans mon cas, l’application Sonos ne fonctionne tout simplement pas. Impossible d’envoyer de la musique (sauf via AirPlay), d’ajouter une enceinte ou de faire une mise à jour. Heureusement, j’ai trouvé la solution et voici comment résoudre le problème en 5 minutes…

sonos - Sonos et Synology : problème de WiFi !

Sonos propose de nombreuses enceintes pour écouter de la musique dans toutes les pièces de sa maison, mais aussi du Home Cinema. Lorsque j’ai acheté ma première enceinte, le vendeur (Fnac) m’avait prévenu que les installations Sonos nécessitaient d’avoir un solide WiFi. Il me conseillait de prendre un boîtier dédié : Sonos Boost (120€). J’ai décliné sa proposition ayant confiance dans mon installation. À l’époque, je disposais d’un RT1900ac. Malgré le nombre d’appareils connectés, l’enceinte n’avait aucun souci pour fonctionner. Plusieurs mois plus tard, j’ai acquis une seconde enceinte puis une troisième. Tout fonctionnait à merveille.

Entre temps, je passais au RT2600ac couplé à un MR2200ac pour avoir une meilleure couverture WiFi. Les enceintes fonctionnaient très bien avec l’installation Synology.

Récemment, Sonos a mis à jour ses enceintes et Synology a sorti une nouvelle version de SRM… et là c’est la catastrophe. J’ai eu l’idée à quelques jours d’écart d’installer Sonos S2, nécessitant une mise à jour du firmware des enceintes… et d’installer SRM 1.2.4. À ne pas refaire, je le sais pourtant, et j’ai perdu du temps à trouver le coupable : Synology.

À chaque tentative d’envoyer du son, l’application Sonos me donnait un code d’erreur différent. Exceptionnellement, le système fonctionnait pendant une chanson, mais impossible de changer l’enceinte ou de piste sans faire tout planter. Lorsque j’éteignais le MR2200ac et redémarrais les enceintes Sonos, cela fonctionnait mieux pendant quelques minutes/heures. Je suis resté comme ceci plusieurs jours, car la configuration fonctionnait en AirPlay 2. C’est aussi pour cette raison que j’ai pensé que cela venait de Sonos (à tort).

Sur les routeurs Synology, quand quelque chose ne va pas, on conseille de désactiver le mode Connexion intelligente (Smart connect) qui permet aux périphériques de basculer automatiquement du 2,4 au 5 GHz. Aussi, on recommande de désactiver les outils comme Safe Access et Threat Prevention. Si cela ne fonctionne pas, il faut essayer de trouver un canal peu encombré (si possible). Malheureusement, rien de tout cela n’a fonctionné pour moi.

Lors d’un week-end de repos en famille (loin du tumulte de la vie quotidienne), je me suis rappelé du changelog de la dernière version de SRM et des mentions de diffusion réseau (broadcast, multicast…). De retour du week-end, j’allume le PC :

  • Connexion à l’interface d’administration de SRM ;
  • Wi-Fi Connect puis menu Sans fil et on clique sur Options avancées ;
  • Et choisir Désactiver en face de Translation de multidiffusion.

SRM mutidiffusion - Sonos et Synology : problème de WiFi !

Le résultat a été immédiat. Dès le premier titre sur Spotify (via Spotify Connect), la première enceinte envoie la musique. Depuis l’application Sonos, il est possible d’activer le mode Party (musique sur toutes enceintes simultanément). Je vais continuer à tester pendant 7 jours directement via Spotify ou l’application Sonos : aucun souci. L’option Translation de multidiffusion est activée par défaut si le réseau est maillé avec SRM 1.2.4. J’ai bien fait attention à tester les autres périphériques connectés (domotique, lecteur multimédia, téléphone, tablette, ordinateur, caméra IP…). Tout fonctionne correctement.

Alors au final, j’ai ouvert un ticket au support Synology pour leur faire-part de mon expérience. Nous échangeons encore sur ce problème. Selon eux, cela provient bien de « Added support to configure multicast translation and IGMP snooping in a mesh Wi-Fi system » récemment ajouté avec la dernière version de SRM.